|
|
环境:windows 7 ,mysql-5.5.18-win32.msi $ {0 a9 y. H& Q9 _8 I$ R
主服务器地址:192.168.1.192, N3 i' Y6 C4 a: C9 n
从数据库地址:192.168.1.193
0 s+ @; _0 \3 p& U9 ops.某些步骤可在phpmyadmin中设置!教程同样实用于linux注意路径即可,要同步的数据库:test1 同步帐号:slavetb8 |: V( i4 i- N+ w, K- f
& I( I1 W6 H B* b0 D
流程:
# V$ w/ J+ d0 N+ z" y主服务器0 I5 G: b% D+ j# K7 H4 c9 b
1:在mysql下找到my.ini文件,在其[mysqld] 下添加主服务器端配置: H" @8 C& U" L5 F! k2 k
server-id=1 #服务器 id & h( p4 f2 y) d
log-bin=C:\Program Files\MySQL\MySQL Server 5.5\mysql-bin #二进制文件存放路径
7 Q4 U" j$ U4 G9 c6 T$ H4 obinlog-do-db=test1 #待同步的数据库' N) _8 J: v8 k- N7 E, a6 {
binlog-ignore-db=information_schema #忽略不同步的数据库,这个可以不用写
* f+ v$ V& V! m# Wbinlog-ignore-db=mysql #忽略不同步的数据库,这个可以不用写
6 i, z- G2 r7 H* Vbinlog-ignore-db=test #忽略不同步的数据库,这个可以不用写
& B9 u; a9 l) T7 _expire_logs_days = 7 #超过7天自动删除日志文件可以防止同步日志文件过大(可选项)
' d Y' a5 C4 t$ I: V- r9 _2 e: Y( {$ g% O0 b
2:保存my.ini文件,重启数据库,然后会在C:\Program Files\MySQL\MySQL Server 5.5 下看到mysql-bin.index 文件和mysql-bin.000001文件;" e) P4 ?* ~# F2 {3 f( q
! k7 w1 [- t. A# s+ l% \
3:通过cmd进入mysql:cd C:\Program Files\MySQL\MySQL Server 5.5\bin输入用户名和密码:mysql -u用户名 -p密码 ( mysql -uroot -proot )
5 }' v$ e% `) r2 b" L+ S- O# h5 ~% ^2 {8 i
4:给要连接的从服务器设置权限:grant replication slave,reload,super on *.* to slavetb@192.168.1.193 identified by '123456'; ps: 给主机192.168.1.193添加权限,用户名:slavetb,密码:123456;注意不要少了;号(只需输入一次就可以了,向数据库中插入一个具有同步权限的帐号,可在phpmyadmin中设置,全局权限管理项选中RELOAD, SUPER, REPLICATION SLAVE即可)
& d3 s+ ]' m: m# z) K2 v5 p A- @0 U5 j D( W
5:输入命令 show master status\G # 找到File 和 Position 的值记录下来在从服务器(Slave)配置同步关系会有用到的。7 ]9 ?3 R" Y5 V! W! f/ B
; h$ J a5 {8 @, N1 c6:备份你要同步的数据库,然后导入从服务器,不要有数据修改添加操作,实在不行可暂时锁下表。
8 l. O9 u9 x* q, u: [( J R( C: I+ L; \5 \
其实,主服务器是不需要设置太多信息的,只需要第1条中的前三行就足够了。下面配置从服务器:" ^# I/ n, |6 Z e$ R* p. a3 G
' N& C* Y* g) `- B7 Y7 O4 i1:在mysql下找到my.ini文件,在其[mysqld] 下添加从服务器端配置:
. ?' D# k6 J5 Z- v1 |server-id=2 #服务器 id ,不能和主服务器一致# Y/ o! J; {' e' ~
replicate-do-db=test1 #待同步的数据库,ps.如果只同步test1中的news表可改成这样:replicate-wild-do-table = test1.news! Z5 _: S5 q* d" g3 @( H* c
binlog-ignore-db=information_schema #忽略不同步的数据库,这个可以不用写) w" e4 m9 x! X, |( p
binlog-ignore-db=mysql #忽略不同步的数据库,这个可以不用写
. O$ G+ D6 |' ~0 xbinlog-ignore-db=mysql #忽略不同步的数据库,这个可以不用写7 k+ T. b$ o! L& _0 d- s. X
binlog-ignore-db=test #忽略不同步的数据库,这个可以不用写
! X% y0 W8 @0 J I: iexpire_logs_days = 7 #超过7天自动删除日志文件可以防止同步日志文件过大(可选项)/ I& i% E+ P4 W
) k) h; t4 U: r9 T2:保存my.ini文件,重启从数据库。ps.在mysql5.1以上版本中有个master设置这里已经取消无效了,如果添加了master设置,数据库就无法重启了; s! p: M S7 ~5 y$ N. a
1 `9 o6 R- b0 ~0 V8 L3:通过cmd进入mysql:cd C:\Program Files\MySQL\MySQL Server 5.5\bin
- T( `( `; n# [; J- r% \: p! d' c* ]8 q8 E1 F Q8 t
4:从服务器上测试:mysql -uslavetb -p123456 -h192.168.1.192,查看能否连接主数据库成功,如果成功,则一定要退出来,之前我就是一直犯了一个错误,按照网上的步骤测试完毕之后就没有退出mysql,结果执行以下步骤时老是报错,其原因是一直设置的是主数据库;& k: P# N+ {' }( Z- Y/ Q% n [& p
+ B$ t7 d- y1 S
5:修改对主数据库的连接的参数:mysql>change master to master_host='192.168.1.193',master_user='slavetb',master_password='1234562', master_log_file='mysql-bin.000001',master_log_pos=107; ps:最后两个中mysql-bin.000001与107为主服务器配置中第5步记录下来的值。可能会报一个错误,大概的意思是说slave线程正在运行,不能设置,这样的话,执行mysql>stop slave; 停止slave线程,然后再设置连接的参数;
; e8 B: K! l& ]- k2 O, d
! B' n% l) h+ x, D6:设置完之后,执行 mysql> start slave; 开启slave线程;执行mysql> show slave status\G (没有分号),查看Slave_IO_Running: Yes
0 b" l: i# t6 S- G- _! VSlave_SQL_Running: Yes0 K7 E) J; p: \* r

3 v8 U$ E! n( ]& l N! A( L: @2 I$ {. k
7:完毕,在这个过程中我的测试结果一直是Slave_IO_Running:No;让我很是郁闷,一直没找到原因,错误代码如下, 后来找到了,其实原因很简单,当我测试连接主数据库之后我没有退出来,造成接下来的所有步骤都是对主数据库的操作; 其实主主同步也是相同的配置,只是相互为主机和从机的设置; |
|