|
|
很多朋友在用IIS6架网站的时候遇到不少问题,而这些问题有些在过去的IIS5里面就遇到过,有些是新出来的,做了很多次试验,结合以前的排错经验,做出了这个总结,希望能给大家帮上忙。
( W; `) O1 {4 j2 A( p+ Q
& B5 ~8 H, Q+ j' C( Y2 C4 D问题1:未启用父路径
$ |5 J/ [4 U, s2 ?/ N! P症状举例:
9 N6 n* a2 M/ |4 u4 t4 |
, I" h6 }/ T" K. }- a Server.MapPath() 错误 \'ASP 0175 : 80004005\'
4 _) R( c$ o+ S' { t, R6 {; a: h4 P! i6 o; g
不允许的 Path 字符
5 J( N7 m7 S& j. }9 _
m% U7 p: W0 b3 a' E* t/ e$ ~ /0709/dqyllhsub/news/OpenDatabase.asp,行 4
8 u+ s9 K( R k, i6 i1 L: [7 i! c! a+ v& g5 `( O6 J! o* k
在 MapPath 的 Path 参数中不允许字符 \'..\'。
5 @& Z) j- z5 o& U. n, l0 L W% V5 X4 y+ W7 f o# ^' j
5 U' p3 p+ E# f5 k: Z* c9 G7 O原因分析:
: ~' g1 ?5 }, W. H3 J$ L
# Y2 v$ k) ]3 Z* [ 许多Web页面里要用到诸如../格式的语句(即回到上一层的页面,也就是父路径),而IIS6.0出于安全考虑,这一选项默认是关闭的。 如果是使用LEADBBS论坛的朋友就要注意了,DV的不会出现问题。" ^/ ^& R/ m' Z s; f$ I
R, _7 s1 B& @6 Y& g2 g
解决方法:! J* F- F' f* ]) l
& A6 ~0 x) M# a+ E- t7 C( F在IIS中属性->主目录->配置->选项中。把”启用父路径“前面打上勾。确认刷新。
! @# ?# I; F$ i0 O! l4 v( s8 R- g; A" @0 R
问题2:ASP的Web扩展配置不当(同样适用于ASP.NET、CGI); Z* ~' o5 A, ]7 y3 d7 S9 Z- Q
4 O' H/ D5 f# ~! Z症状举例:
; S5 U3 E' ^. d# l
3 l9 ~. R L' { [# H! EHTTP 错误 404 - 文件或目录未找到。1 i5 e( K& [; f& t
G1 v: F. l# c1 f原因分析:
: g8 }& u- ?( x- @* v* K# ]% Z4 A' c1 k) K4 [3 d" s
- `, s3 R" d2 ?6 u2 g 在IIS6.0中新增了web程序扩展这一选项,你可以在其中对ASP、ASP.NET、CGI、IDC 等程序进行允许或禁止,默认情况下ASP等程序是禁止的。$ J& v: J1 Y5 S, T4 Z
2 X4 q8 P# p/ e% k! @
解决方法:" @0 n' H% A% E9 i
1 h" L" r i( r8 m9 J! l B
在IIS中的Web服务扩展中选中Active Server Pages,点击“允许”。
6 H1 w: c" g l3 n
: f5 g q* b. r" [! Z问题3:身份认证配置不当
( R% M& B5 s- b9 }' m- R
: ~; x+ k/ H7 q8 X症状举例:
; s9 o _2 H. t* l. F0 d/ t; f3 e5 l6 [& F! w/ x" H4 x' U
HTTP 错误 401.2 - 未经授权:访问由于服务器配置被拒绝。! I8 h; Z# ~4 u: g: i) a
% T0 T/ ]" A& w M; a* K; e8 I, B
原因分析:
3 a7 J- h* K I# y. V8 H* R% ]$ Y. [3 j5 C; A
IIS 支持以下几种 Web 身份验证方法:" n) f3 S8 ]' E7 g, H; W; d
$ Y5 M3 P2 V, A3 }8 j
(1)匿名身份验证1 z3 H m, v% w: [8 L% T a
* y6 S" x3 q% }* M( d* ]
IIS 创建 IUSR_计算机名称帐户(其中计算机名称是正在运行 IIS 的服务器的名称),用来在匿名用户请求 Web 内容时对他们进行身份验证。此帐户授予用户本地登录权限。你可以将匿名用户访问重置为使用任何有效的 Windows 帐户。6 I: F8 G9 w( ?3 ~% d' b, S8 Z
% }0 E% u6 `, G8 d& t" Y g3 A! M
(2)基本身份验证
: s: j* K7 {* Y8 m g, p, d: H+ G/ y. |* A
使用基本身份验证可限制对 NTFS 格式 Web 服务器上的文件的访问。使用基本身份验证,用户必须输入凭据,而且访问是基于用户 ID 的。用户 ID 和密码都以明文形式在网络间进行发送。) G# o0 a# q$ D$ b5 R# W: k
8 e6 k1 Q3 v$ `1 z6 _# c# U% V- T9 U(3)Windows 集成身份验证
1 g% u' x: o, ]3 z) i
* P% ~* @7 `8 A, f; V7 r: ~9 j' Q( N Windows集成身份验证比基本身份验证安全,而且在用户具有Windows域帐户的内部网环境中能很好地发挥作用。在集成的Windows 身份验证中,浏览器尝试使用当前用户在域登录过程中使用的凭据,如果尝试失败,就会提示该用户输入用户名和密码。如果你使用集成的Windows身份验证,则用户的密码将不传送到服务器。如果该用户作为域用户登录到本地计算机,则他在访问此域中的网络计算机时不必再次进行身份验证。8 P6 A; Y r6 @# k
$ [, D. h) L+ U1 A# e7 a(4)摘要身份验证
3 p( Y) E- X( H9 B4 |) r- {" b+ ?+ N6 I' R' [ |' A
摘要身份验证克服了基本身份验证的许多缺点。在使用摘要身份验证时,密码不是以明文形式发送的。另外,你可以通过代理服务器使用摘要身份验证。摘要身份验证使用一种挑战/响应机制(集成 Windows 身份验证使用的机制),其中的密码是以加密形式发送的。
( t7 d9 X" {* D% r4 z6 _3 S+ _ A+ y5 S k" h
.NET Passport 身份验证
5 S+ J5 R, r$ y Y; x) c" j. S" _" Z
Microsoft .NET Passport 是一项用户身份验证服务,它允许单一签入安全性,可使用户在访问启用了 .NET Passport 的 Web 站点和服务时更加安全。启用了 .NET Passport 的站点会依靠 .NET Passport 中央服务器来对用户进行身份验证。但是,该中心服务器不会授权或拒绝特定用户访问各个启用了 .NET Passport 的站点。
- w: d& R' o+ {5 t% w6 O$ {1 J
! K) `' f0 r2 [1 W: Z6 [( }解决方法:( }/ Z4 T4 c+ s% ^' n
2 N$ C% [) R7 V( g" Q. @+ d8 a+ W
根据需要配置不同的身份认证(一般为匿名身份认证,这是大多数站点使用的认证方法)。认证选项在IIS的属性->安全性->身份验证和访问控制下配置。
, J0 b8 P* i/ ^$ x$ Q# E% i2 R" \6 u7 A8 W8 z: W
c: ~& |% n( U& F
问题4:IP限制配置不当
' b! I8 y+ L- v6 L2 V
3 f; M- Y( a' A症状举例:4 j0 ~2 k0 M1 R; Z6 S. M0 |, g8 s
- U6 V- U% B' d+ j; ~, U3 C' K7 v
% ^9 W8 H `; V9 ?; g& Y( e% g
HTTP 错误 403.6 - 禁止访问:客户端的 IP 地址被拒绝。0 L4 C! c* ^( g" e; J! q
" J$ e" y. g* X# W2 c( P. ~# y原因分析:+ t$ u+ { _5 l3 H$ h) u% H8 X
9 R% Y h- h+ y
- W& j) W; R: ?2 i) o" P
IIS提供了IP限制的机制,你可以通过配置来限制某些IP不能访问站点,或者限制仅仅只有某些IP可以访问站点,而如果客户端在被你阻止的IP范围内,或者不在你允许的范围内,则会出现错误提示。2 o9 `3 b# {0 L
! p: t+ j, m& j
解决方法:2 v4 V1 b( F9 W2 k1 C4 y5 k
) ?, U, g; a: E0 A+ e进入IIS的属性->安全性->IP地址和域名限制。如果要限制某些IP地址的访问,需要选择授权访问,点添加选择不允许的IP地址。反之则可以只允许某些IP地址的访问。+ e" `: e: [7 ~
7 E' I! P1 ?) m9 Z" ~/ I6 ~% m问题5:IUSR账号被禁用
% s! A& {1 s x4 @7 g* f& W+ x5 d% {% {! D' a. h6 u
症状举例:
3 a, J2 D5 Q2 P+ V; G, B
/ p* ^) c1 Y# |7 [5 J' p2 V+ N: ^: w/ Q+ w' U+ e4 f
HTTP 错误 401.1 - 未经授权:访问由于凭据无效被拒绝。
4 E: W7 i" g3 ]' h+ d2 I, n" F$ ~+ m+ w
原因分析:% i- Y0 _5 z/ s _$ j! `
4 Z* `8 |# ~" r. y& ~ Q
. ~3 s% g8 @# S9 W5 N: Z) B 由于用户匿名访问使用的账号是IUSR_机器名,因此如果此账号被禁用,将造成用户无法访问。
! X% x6 s6 m, _8 k2 F" m! p, @8 H( f$ K. ]2 b+ f
解决办法:
5 C, a5 R2 `1 @ Z$ B+ _. D0 n5 H: [3 H! Z4 @+ Q# ?& D7 }
控制面板->管理工具->计算机管理->本地用户和组,将IUSR_机器名账号启用。; I! X+ D" S3 v4 O' I
; j. }$ R9 n7 R& Q问题6:NTFS权限设置不当
" P9 ]( t. \( Z# {; b) P- e. A症状举例:
4 M9 @) E$ R" I( O' V g+ S7 V/ l9 e; ?8 o- g4 \* m# t' l
* `0 a7 S b( `: `, ^
HTTP 错误 401.3 - 未经授权:访问由于 ACL 对所请求资源的设置被拒绝。
8 }6 ]7 R" K/ k5 f
1 o+ z8 ^; T: G. W5 h- f原因分析:# t7 ^6 S+ ?0 h
/ q" n' c* O) U6 r0 d' W$ i( p' R! a/ F2 h7 O
Web客户端的用户隶属于user组,因此,如果该文件的NTFS权限不足(例如没有读权限),则会导致页面无法访问。
+ }; A( L' F1 t) n$ G1 A0 i+ R* W( `* ?3 t3 @" g' G* P
解决办法:6 p: C7 } T$ c! c# y8 W
2 L) R; K- [ Z: {/ P) b
9 C- l. y" W; I& U( E+ S2 M3 c 进入该文件夹的安全选项卡,配置user的权限,至少要给读权限。关于NTFS权限设 置这里不再馈述。
2 w' Y/ F; k% M5 ]4 r" s4 u+ _/ x# c/ r1 {, }
问题7:IWAM账号不同步
! L( s* f. Z5 L* r0 V7 m/ @: E2 J7 `1 ]
注意:这个问题经常出现!!!!6 |, D1 S" Q1 \- I9 R! [' ]" m
症状举例:
: M V8 V7 F7 H3 S# G! U8 Q
3 H& I0 {* E' v, |2 N4 q! X# T* f! W D, e+ `
HTTP 500 - 内部服务器错误
1 b4 G- O. e$ R' I% q7 z' k' e- [! V! {& j+ j' {: \3 R
原因分析:
1 ^2 S6 C3 H8 g" V4 q& n9 p
j! V6 p/ X4 c" y& l# j; t9 a- M; I
+ x: O1 t ]7 ?4 | IWAM账号是安装IIS时系统自动建立的一个内置账号。IWAM账号建立后被Active Directory、IIS metabase数据库和COM+应用程序三方共同使用,账号密码被三方分别保存,并由操作系统负责这三方保存的IWAM密码的同步工作。系统对IWAM账号的密码同步工作有时会失效,导致IWAM账号所用密码不统一。3 K3 ~3 \) U# N8 y* {
. f# i7 `$ ]+ n( K) f7 u解决办法:
: \9 e w( @1 w6 }# \6 K( x
! \+ e6 r5 N- ^7 S% Y
/ n9 W+ M2 V/ Y" p 如果存在AD,选择开始->程序->管理工具->Active Directory用户和计算机。为IWAM账号设置密码。运行c:\Inetpub\AdminScripts>adsutil SET w3svc/WAMUserPass +密码同步IIS metabase数据库密码运行cscript c:\inetpub\adminscripts\synciwam.vbs -v 同步IWAM账号在COM+应用程序中的密码# [, k5 Q( P+ u' |
, L1 {6 q% C1 J3 k* H
问题8:MIME设置问题导致某些类型文件无法下载(以ISO为例)
; T9 R+ b* @4 {: a2 m; A" y# q0 e. |6 o# v( |7 v
症状举例:8 F3 \/ s1 z. C! a, w% b" ?6 D
% I1 v/ T8 O/ v, z$ n9 Q0 b! R8 C HTTP 错误 404 - 文件或目录未找到。' y( B' \! T1 z5 ~3 P" D4 x
8 o. v3 a4 @ Y# {2 r" o原因分析:
( O+ N C! a( U8 K# x0 `3 f- g" [' u% k- t8 h: L
IIS6.0取消了对某些MIME类型的支持,例如ISO,致使客户端下载出错。
4 O& C1 t& O0 L3 W8 P% A3 _7 w+ m& M! U. D3 [& l& t
解决方法:% p X1 F5 t n3 J4 H+ h% Z
& T, y) R# V4 }; ~ 在IIS中属性->HTTP头->MIME类型->新建。在随后的对话框中,扩展名填入.ISO,MIME类型是application。
9 a v2 E' g0 X
- N- y7 u4 u8 |3 Z另外,防火墙阻止,ODBC配置错误,Web服务器性能限制,线程限制等因素也是造成IIS服务器无法访问的可能原因,这里就不再一一馈述了。( z3 ^3 G! m6 D9 m M
|
|